Exchange Management Console Database Recovery

Exchange Management Console Database Recovery

I now extracted a new copy of the mailbox database from the backup, using NTBackup again. I restored it to my desktop, not the original location. I opened MS Exchange 2007 MC, and clicked on Toolbox in the navigation pane. Then I clicked on Database Recovery Management. I left everything default and hit next, next.

  1. I clicked Create a Recovery Storage Group.
  2. I left everything as default, default name, and linked it to the First Storage Group, which now contains my current mailboxes.
  3. After the wizard completed, I navigated to the location of the storage group folder, which is inside my First Storage Group folder.
  4. I copy all of the files from the restored Exchange database folder- about 3 Gb in 25 files.
  5. I then try to mount the database from inside the Database Wizard- which comes back with some MapiCallError. Gah!
  6. So I run Repair Database. It gives me a warning- but at this point, who cares.
  7. I let it run, and it completes. And the database mounts successfully!

Now how do I get the mail back? I run the Merge or Copy wizard, which I zip through not really knowing what is going on- and after completion, it restored no mailboxes, the GUID did not match. So I take some more time, and click advanced options. I match and sort by Mailbox Name and try to merge again- still an error with the matching. So I go back into advanced options, and I Restore them to my admin mailbox. I create a folder called Restore, and select all the mailboxes to restore. This runs for a while, and I am seeing items appear.

And then they stop appearing, and my email slows to a crawl. Ugh, Exchange. I delete all of the exported items, half of which did not show up anyhow. So I decided to try a slower approach. I export ONE users mailbox into my mailbox at a time, and it worked. I then exported each of the items from that restored mailbox out of Outlook to a shared folder. I go to a workstation, and log in as that user, and then import their old mail items back into their Exchange mailboxes. It works, thank God. There is a way to do it from the server using EMS, but this requires Exchange Tools 32bit, which you can’t install on a 64bit server. So since I would need to go to another PC anyways, I might as well just restore them from PST files. A whole lot of this episode could have been avoided by knowing exactly what was going on- which I now do. If anyone needs any advice, please feel free to post here and I will do my best to provide the appropriate resources.

Advertisements